« Happy hoursTout va très bien, madame la marquise... »

Logiciels dentaires

16.09.15 | par Le Grincheux | Catégories: Mauvaise humeur, Je hais l'informatique

Parmi mes clients, enfin parmi ceux qu'il me reste et qui n'ont pas encore mis la clef sous la porte, figurent quelques dentistes. Et parmi ces dentistes, beaucoup utilisent l'inénarrable logiciel pompeusement intitulé Visiomachin (remplacer machin par l'objet à forer ou à arracher de prédilection des dentistes).

Ce logiciel est un truc mal ficelé, écrit avec des pieds, qui surcharge les pilotes de Windows par les siens, provoquant des lenteurs inexplicables ou des instabilités rigolotes, et qui utilise une base de données avec des vrais bouts de 16 bits à l'intérieur. On arrivait encore à le faire fonctionner sous Windows 7 32 bits, mais plus sous les versions plus récentes du système d'exploitation. Pourtant, la ligne 100 du logiciel est toujours supportée et le founisseur ne se prive pas d'envoyer des factures tous les ans aux praticiens pour les licences, les mises à jour et les menues opérations de configuration.

Or dans un cabinet, je vais être contraint de changer les postes clients. Quitte à changer ces postes, autant mettre une configuration pas trop obsolète. J'opte donc pour du Windows 7 Pro en 64 bits puisqu'il y a un contrôleur de domaine (Unix) avec des profils itinérants. Le logiciel installé ne fonctionnera donc plus parce que cette fichue base de données (Pervasive pour ne pas la nommer) refuse de s'installer sur les postes clients. Je n'ai pour ma part jamais compris pourquoi Visiomachin était incapable d'utiliser une base de données en réseau plutôt qu'un truc pareil qui est à la base de données ce que la musique militaire est à la musique. Je ne sais pas si vous voyez bien ce que je veux dire, seuls les plus anciens ayant servi sous les drapeaux.

C'est d'autant que depuis 2012, il y a à la fois une base Pervasive et une PostgreSQL.

Coup de fil donc au technico-commercial de Visiomachin pour savoir comment régler le problème. « Très simple, monsieur, il vous faut la ligne 500 de notre logiciel qui lave plus blanc. Ça vous coûtera tant. » Chose amusante, il s'agit d'un tout autre logiciel, avec une autre interface et une autre base de données. Il y a donc une migration quelque part et cette migration de base ne peut se faire que dans les locaux de Visiomachin, ce qui impose des vacances forcées au cabinet. Et lorsque je parle d'une autre interface, cette dernière requiert un écran FullHD (1920x1080 points). Problème, les normes des écrans sur les fauteuils imposent des écrans très spécifiques qui n'existent qu'en 1280x1024 en 17 ou 19 pouces (vitre sur la dalle pour éviter des projections, alimentation basse tention et j'en passe). Les mobiliers standards des cabinets ne permettent que d'utiliser des écrans de 17 pouces. Un écran plus grand entrave l'ouverture des portes et si les dalles existent (pour les ordinateurs portables), je n'ai pas réussi à trouver un écran de bureau FullHD en 17 pouces qui ne soit pas à un prix prohibitif.

Les migrations NGAP/CCAM, les mises à jour SV 1.31 vers 1.40 m'ont toujours paru bricolées pour ne pas dire que j'avais l'impression d'essuyer les plâtres avec des briques. Là, le praticien se retrouve dans la situation de devoir changer son mobilier car un logiciel refuse de fonctionner normalement en-dessous de la résolution FullHD et il me faut trouver les arguments pour faire passer cela au praticien qui, s'il est excellent dentiste, n'est pas informaticien mais commence à se douter qu'il se fait prendre pour une vache à lait par un éditeur de logiciel. Surtout qu'il n'y a aucune raison technique à avoir besoin d'une telle résolution.

Peut-être dois-je lui suggérer de changer de logiciel ?

 

Aucun commentaire pour le moment


Formulaire en cours de chargement...

Une erreur inattendue est survenue!

Si cette erreur persiste, merci de la signaler à l'administrateur.

Retourner à la page d'accueil

Informations additionnelles à propos de cette erreur:

MySQL error!

Incorrect key file for table './b2evolution/evo_hitlog.MYI'; try to repair it(Errno=126)

Your query: Autopruning hit log

DELETE
  FROM evo_hitlog
 WHERE hit_datetime < "2018-01-08"